Incident

Incident Majeur Plateforme de paiement / Major incident Payment Platform

Closed | Jan 20, 2022 | 10:04 GMT+01:00

Rapport d’incident 90722

Début de l'incident : 18/01/10/2022 14H00
Fin l'incident : 18/01/10/2022 17H55

SERVICE IMPACTE

Service de Paiement via l’API formulaire embarqué
Tous les autres paiements effectués via les autres API sont restés fonctionnels ( Page de paiement en redirection , Paiement Vad depuis le BO etc …. )

IMPACT MÉTIER CLIENT

50% des paiements effectués depuis l’API formulaire embarqué sont en échec.
Toutes les autres API sont fonctionnelles ( Page de paiement , Paiement Vad depuis le BO etc …. )

ANALYSE ET DIAGNOSTIC

Tous les liens inter-sites ont été coupés suite à des travaux de voirie sur l’ensemble des opérateurs connectés à la plateforme.
800 fibres optiques ont été impactées et 3 de nos fibres ont été coupées malgré l’assurance de l’opérateur que celles-ci empruntaient des chemins terrestres différents.)

Chaque site est autonome donc l’ensemble des services était opérationnel excepté le service de paiement via l’API formulaire embarqué qui a été impacté à 50%.
Cette API se décompose en deux appels :
- L’initialisation du paiement
- L’appel au formulaire embarqué qui s’affiche sur la page du site marchand
Si l’initialisation du paiement se fait sur le site 1 et l’appel au formulaire embarqué sur le site 2 alors le paiement est refusé car il est impossible de retrouver la clé d’initialisation.

ACTIONS

18/01/2022 14h Incident déclarés chez SFR.
18/01/2022 17H55 Mise en place d’une solution de contournement : lien inter-site sur internet avec un retour des services à la normale.
19/01/2022 14H00 l’ensemble des fibres optiques sont opérationnelles / Bascule sur l’architecture nominale / solution de contournement désactivée

_________________________________________________________________

Report of incident 90722

Start time 2022/01/18 2:00 PM
End time : 2022/01/18 5:55 PM

SERVICE IMPACTED

Payment service using the API embedded formulaire
All the other service of payment was up as the redirect payment , payment MOTO from the BO ..... )


IMPACT CUSTOMER

50% oh the payment using the API embedded form was unsuccessfull
The others payments was up as the redirect payment , payment MOTO from the BO.

ANALYSE

Cut of the network between the production sites following civil engineering work. 800 opticals networks was impacted and our 3 optical network was cut even though our provider gave us the assurance that those one using differents physicals ways.

Every site is independant so every service was up excepted the payment from the API embedded form impacted for 50%.
This API uses 2 requests
- Initialisation of payment
- display of the payment form on the website merchant.
If the initialisation is perfomed on the plateform site 1 and the request for the display on the site 2 then the payment is failed because it is not possble to find the token of intialisation ( Payment Token )

ACTIONS

2022/01/18 2:00 PM Incident opened at SFR ( The provider telecom ).
2022/01/18 5:55 PM Workaround solution : Network connexion over internet etablished between the sites of production. All the services are up .
2022/01/19 2:00 PM Opticals networks are UP / switch to the nominal architecture / Workaround solution disabled .

Affected components

  • E-commerce technical platform

Resolved | Jan 19, 2022 | 14:00 GMT+01:00

Suite à la remise en services des fibres par SFR , la solution de contournement appliquée a été arrêtée. L'infrastructure de la plateforme est donc nominale.
---------------------------------------------------------------------------------------------
Following the restoring of the optical network by SFR, the workaround solution has been stopped. So , the infrastructure of the platform is nominal.

Monitoring | Jan 18, 2022 | 18:11 GMT+01:00

Une solution de contournement a été appliquée.
L'ensemble des services de paiement en temps réels sont à nouveau opérationnels.

-------------------------------------------------------------------------------------------

The service of payment online are operationals again following a workaround

Identified | Jan 18, 2022 | 16:41 GMT+01:00

L'incident SFR qui impacte nos liens induit une dégradation du service de paiement sur l'API Paiement Embarqué ( 30% des paiements impactés - paiements refusés )

SFR confirme une coupure de plus de 800 fibres suite à des travaux génie Civil.

Nous travaillons sur une solution de contournement.

The incident SFR connection causes a disruption of the payment service on the API embedded . ( 30% of the payment embedded denied )

The provider SFR confirms a cut of more than 800 optical networks following civil engineering work

A workaround is in progress.

Open | Jan 18, 2022 | 15:31 GMT+01:00

Nous rencontrons actuellement un problème avec un de nos liens opérateur SFR.Quelques ralentissements mineurs sont possibles. L’investigation est en cours avec SFR.

--

We are facing a problem with our SFR connection. Some minor slowdown are possible. Investigation is in progress.

Status Page powered by Admin Labs